Your system supports:

TLS 1.2


Your system is compatible with PSI encryption standards.